Problema con el adaptador de puente de VirtualBox

Recientemente adquirí un adaptador USB inalámbrico de alta potencia 300Mbps marca tp-link, modelo TL-WN8200ND

TL-WN8200ND

No tengo quejas en cuanto a la conectividad del dispositivo, lamentablemente al tratar de configurar este dispositivo como adaptador de puente (bridge adapter) para tener acceso SSH desde la red. al intentar iniciar una maquina virtual aparece este error:

Buscando en la red no encontré una solución para hacer funcionar el dispositivo en modo bridge adapter. Igual seguía teniendo la necesidad de conectarme a través de SSH con putty para administrar desde consola (copiar y pegar comandos principalmente). Encontré una posible solución aunque con algunas limitantes.

Usar múltiples adaptadores de red

Según el manual de configuración de red de Virtualbox:

ModeVM→HostVM←HostVM1↔VM2VM→Net/LANVM←Net/LAN
Host-only+++
Internal+
Bridged+++++
NAT+Port forward+Port forward
NATservice+Port forward++Port forward

Se puede utilizar un adaptador en modo NAT para acceder a internet y un adaptador Host-only para acceder desde el anfitrión a la maquina virtual.

Adaptador 1 NAT
Adaptador 2 Host-Only

Activar el servicio DHCP en VirtualBox

En Host Network Manager de VirtualBox (Ctrl+H) podemos activar el servicio DHCP:

En mi caso estoy usando una maquina virtual con debian, el nombre que el sistema le asigna al adaptador Host-only es enp0s8, este adaptador viene desactivado en el inicio del sistema. Para habilitarlo edité el archivo /etc/network/interfaces y agregue este dispositivo para que se le asigne una dirección ip por DHCPal inicio:

Con esta configuración solo queda reiniciar y configurar putty para acceder a la maquina virtual por red:

Configuración de Putty

La ip que se asigna es la mas baja en el rango de direcciones del servicio DHCP, en este caso 192.168.56.1

Y voilà, tenemos acceso

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *